
Journal of Visualized Experiments www.jove.com

Copyright © 2013  Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported
License

November 2013 |  81  | e50643 | Page 1 of 12

Video Article

Using Continuous Data Tracking Technology to Study Exercise Adherence in
Pulmonary Rehabilitation
Amanda K. Rizk1,2,3, Rima Wardini2,3, Emilie Chan-Thim1,2,3, Barbara Trutschnigg3, Amélie Forget3, Véronique Pepin2,3

1Individualized Program, Concordia University
2Department of Exercise Science, Concordia University
3Centre de Recherche, Axe Maladies Chroniques, Hôpital du Sacré-Coeur de Montréal

Correspondence to: Véronique Pepin at v-pepin@crhsc.rtss.qc.ca

URL: https://www.jove.com/video/50643
DOI: doi:10.3791/50643

Keywords: Medicine, Issue 81, Data tracking, exercise, rehabilitation, adherence, patient compliance, health behavior, user-computer interface.

Date Published: 11/8/2013

Citation: Rizk, A.K., Wardini, R., Chan-Thim, E., Trutschnigg, B., Forget, A., Pepin, V. Using Continuous Data Tracking Technology to Study
Exercise Adherence in Pulmonary Rehabilitation. J. Vis. Exp. (81), e50643, doi:10.3791/50643 (2013).

Abstract

Pulmonary rehabilitation (PR) is an important component in the management of respiratory diseases. The effectiveness of PR is dependent upon
adherence to exercise training recommendations. The study of exercise adherence is thus a key step towards the optimization of PR programs.
To date, mostly indirect measures, such as rates of participation, completion, and attendance, have been used to determine adherence to PR.
The purpose of the present protocol is to describe how continuous data tracking technology can be used to measure adherence to a prescribed
aerobic training intensity on a second-by-second basis.

In our investigations, adherence has been defined as the percent time spent within a specified target heart rate range. As such, using a
combination of hardware and software, heart rate is measured, tracked, and recorded during cycling second-by-second for each participant,
for each exercise session. Using statistical software, the data is subsequently extracted and analyzed. The same protocol can be applied to
determine adherence to other measures of exercise intensity, such as time spent at a specified wattage, level, or speed on the cycle ergometer.
Furthermore, the hardware and software is also available to measure adherence to other modes of training, such as the treadmill, elliptical,
stepper, and arm ergometer. The present protocol, therefore, has a vast applicability to directly measure adherence to aerobic exercise.

Video Link

The video component of this article can be found at https://www.jove.com/video/50643/

Introduction

Pulmonary rehabilitation (PR) combines exercise training, patient education and psychosocial support, and is widely recognized as a cornerstone
in the management of pulmonary disease1-5. The goals of PR are to reduce symptoms, optimize functional status, improve health-related quality
of life, and reduce health care costs4,5. In a meta-analysis of 31 randomized controlled trials in chronic obstructive pulmonary disease (COPD),
PR was shown to significantly improve exercise capacity, reduce dyspnea and fatigue, improve emotional function and enhance patients’
sense of control over their condition6. Furthermore, evidence documents its effectiveness in reducing respiratory exacerbations7 and days
spent in hospital8-13. Exercise training is considered the key to successful PR since it is responsible for much of the benefits associated with
this intervention3-5. However, a major issue for several patients is adhering to the recommended amount or level of exercise. Nonadherence to
recommended treatment may result in the failure of therapeutic interventions as well as inefficient use of health resources14.

According to the World Health Organization, the term ''adherence'' refers to the extent to which a person’s behavior coincides with
recommendations given by a health care professional15. To date, adherence to exercise training in rehabilitation settings has been largely
assessed as either the rate of participation (i.e registration to the program), the rate of completion (i.e. finishing the program), or the rate of
attendance (i.e. number of exercise sessions attended)16-18. At present, no "gold standard" exists for measuring adherence15 and current
methods do not allow for great precision. Furthermore, depending on the selected method, rates of adherence to PR have shown large
variability16-19. For example, Hogg et al.16 measured adherence in COPD patients as the ratio between those who completed the program to
those referred and found a low adherence of approximately 40%. However, other PR studies that have used attendance rates demonstrated,
on average, a 90% adherence10,20,21. The lack of homogeneity in calculating adherence makes it difficult to compare results between studies.
Another concern is the lack of precision with the existing calculation methods; attendance to an exercise training session does not guarantee
adherence to the prescribed intensity. This gap in information led us to investigate how adherence could be calculated in a more precise way.

Recent advances in fitness equipment technology have allowed for continuous data tracking, which can be used to monitor adherence to a
prescribed aerobic training intensity during individual exercise sessions in a PR context. More specifically, data tracking hardware and software
permits for second-by-second recording of duration, speed, level, wattage, pace, heart rate, distance, calorie consumption, VO2, METS, and
calories, and provides averages of all variables with the exception of level and VO2. The main advantage of this technology is the ability to record
continuous detailed measures, which allows for the precise calculation of adherence to prescribed exercise versus previously reported general
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attendance or completion rates. This procedure can be of value for any study examining the impact of one or several aerobic exercise training
programs. Using this technology, patient adherence to a prescribed intensity can be assessed by the percent time spent at a specified wattage,
level, speed, or heart rate during the training phase of each session. For our investigations, adherence to an exercise training protocol has
been defined as the percent time spent within a specified target heart rate range. Since heart rate response at a given submaximal workload
decreases as cardiorespiratory fitness increases, this approach ensures that patients remain at the same relative (versus absolute) training
intensity throughout the program. The present protocol describes in detail how continuous data tracking technology can be used to precisely
measure adherence to a prescribed target heart rate range.

Protocol

Once data is collected, a single file per subject per session of raw data is obtained. Using statistical software, all sessions per subject are
combined into a single file. Subsequently, the target intensity must be calculated for each subject. The adherence rate to that target intensity can
then be calculated per session per subject, for each session for all subjects combined, or per group.

1. Data Collection (carried out by personnel supervising the training session)

1. Minimize electrical interference by turning off wireless devices (e.g. cell phones, Wi-Fi, etc.) and minimize crosstalk by ensuring the heart rate
monitors and equipment are at least 1 meter apart. Refer to Figure 1 for placement of heart rate transmitter.

2. Turn on the data tracking software. Press start on the aerobic equipment and train the participant at the target intensity. For example, in our
studies, participants are asked to train within ± 5 beats/min of their target heart rate. Refer to Figure 2 for CardioMemory.

3. Collect data second-by-second for each participant for each rehabilitation session. Collected data includes the following: subject ID, duration
(hhmmss), level of intensity (1-30), workload (watts), pedaling speed (revolutions/minute), distance (km), pace (mm:ss/km), heart rate (beats/
minute), estimated oxygen consumption (VO2, ml/min/kg), metabolic equivalent of physical effort (METs), estimated energy expenditure (kcal/
hour), and estimated energy consumed (kcal). See Figure 3.

4. Press stop on the aerobic equipment. Click "save" to upload the data to CardioMemory. Click "export" to save the document outside of
CardioMemory. The document will be in .cvs format and will automatically include the date of the session.

2. Data Extraction

CardioMemory software does not allow for the distinction of various exercise-training phases. As such, the data obtained must be exported to
a statistical software in order to eliminate the phases that are not of interest (e.g. warm-up and cool-down), merge the data files, and compare
achieved against target intensity.

1. Open statistical analysis software to import excel file. Procedure: File → Open → Data → In "Open Data" window, select All Files in the
dropdown menu of "Files of Types" → Select Excel. xls file → Open → In "Opening Excel Data Source" window click OK.

2. Save the data file in a statistical analysis software. See Figure 4 for a sample database.
3. Eliminate the nontraining phases, i.e. warm-up and cool-down, if the interest is time spent at the target intensity during the training phase.

1. Eliminate warm-up phase (e.g. first 10 min):
1. To recode duration, create a variable to identify every second as 1. Procedure: Transform  → Recode into Different variables…

→ In "Recode into Different Variables" window, select Duration_A img alt="Arrow" fo:content-width=".2in" src="/files/
ftp_upload/50643/arrow.jpg" width="20px" /> click arrow → Identify "Output Variable Name" (e.g. tempo) → Change → Click on
Old and New Values → Under "Old Value", select Value: and enter 0 → Under "New Value", Select Value: and enter 0 → Add →
Under "Old Value", select All other values then click on Value:, under "New Value" and enter 1 → Add → Continue → OK.

• RECODE Duration_A (0=0) (ELSE=1) INTO Tempo.
• EXECUTE.

2. Create a second temporary variable. Procedure: Transform → Shift Values  → Select tempo → Click arrow → Under "Name:"
type temporary variable (e.g. tempo2) → Change → OK.

• SHIFT VALUES VARIABLE=Tempo RESULT=Tempo2 LAG=1.

3. To start tempo2 at 0, it must be recoded. Procedure: Transform → Recode into Same Variables → Select tempo2 → Click arrow
→ Click Old and New Values → Under "Old Value", select System-Missing → Under "New Value", select Value: and enter 0 →
Add → Continue → OK.

• RECODE Tempo2 (SYSMIS=0).
• EXECUTE.

4. Sum the seconds starting from zero. Procedure: Transform → Compute Variable → Under "Target Variable:" type tempo →
Under "Numeric Expression" type lag (tempo) +1 → IF... → Select Include if case satisfies condition: → Type tempo2 > 0 →
Continue → OK.

• IF (Tempo2 > 0) Tempo=Lag (tempo) + 1.
• EXECUTE.

5. To eliminate the first 10 min of warm-up, remove tempo data that precedes 599 seconds. Procedure: Data → Select cases… →
In "Select Cases" window, under "Select", choose "If condition is satisfied" → If… → In "Select Cases: If" window, insert equation
tempo > 599 → Continue → Under "Output", choose Delete unselected cases → OK. See Figure 5.

• FILTER OFF.
• USE ALL.
• SELECT IF (tempo > 599).
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• EXECUTE.

2. Eliminate cool-down phase (e.g. last 5 minutes):
1. Sort data in descending order for Duration_A to bring the cool-down phase to the top of the database, as SPSS removes data

from the top of the file onwards. Procedure: Data  → Sort Cases → In "Sort Cases" window, select Duration_A → click arrow →
In "Sort Order" menu select Descending → OK.

• SORT CASES BY Duration_A(D).

2. Recode Duration_A to identify every second as 1. Procedure: Transform  → Recode Into Different variables… → In "Recode into
Different Variables" window, select Duration_A → click arrow →  Identify "Output Variable Name" (e.g. tempoA) → Change →
Click Old and New Values → Under "Old Value", select Value: and enter 0 → Under "New Value", select Value: and enter 0 →
Add → Select All other values under "Old Value", then click on Value: under "New Value" and enter 1 → Add → Continue → OK.

• RECODE Duration_A (0=0) (ELSE=1) INTO TempoA.
• EXECUTE.

3. Create a second temporary variable. Procedure: Transform → Shift Values  → Select tempoA → Click arrow → Under "Name:"
type temporary variable (e.g. tempoA2) → Change → OK.

• SHIFT VALUES VARIABLE=TempoA RESULT=TempoA2 LAG=1.

4. To start tempoA2 at 0, it must be recoded. Procedure: Transform → Recode into Same Variables → Select tempoA2 → Click
arrow → Click Old and New Values → Under "Old Value", select System-Missing → Under "New Value", select Value: and enter
0 → Add → Continue → OK.

• RECODE TempoA2 (SYSMIS=0).
• EXECUTE.

5. Sum the seconds of the tempoA variable. Procedure: Transform → Compute Variable → Under "Target Variable:" type tempoA
→ Under "Numeric Expression" type lag (tempoA)+1 → IF... → Select Include if case satisfies condition: → Type tempoA2> 0 →
Continue → OK.

• IF (TempoA2 > 0) TempoA=Lag (tempoA) + 1.
• EXECUTE.

6. To eliminate the cool-down phase (i.e. 5 min), remove tempo data that precedes 299 seconds. Procedure: Data → Select
cases… → In "Select Cases" window, under "Select", choose "If condition is satisfied" → If… → In "Select Cases: If" window,
insert equation tempoA > 299 → Continue → under "Output", choose Delete unselected cases → OK. See Figure 6.

• FILTER OFF.
• USE ALL.
• SELECT IF (tempoA > 299).
• EXECUTE.

3. Identify the session number (or date) associated with the dataset. Create and name a new variable (e.g. Session). Procedure:
Transform → Compute Variable  → In compute variable window under Target Variable, type Session → click Type & Label to open
"Compute Variable: Type an..." window → under "Type" select String → Continue → under String Expression type '1' → OK. See
Figure 7.

• STRING Session (A8).
• COMPUTE Session= '1'.
• EXECUTE.

4. Save the modified SPSS document in a new file (example: subjectID_session#).
5. Repeat the above procedure for all remaining sessions for the same subject.

3. Data Merging - Single Participant

1. To merge all sessions into a single SPSS database, open participant's first session (i.e. subjectID_session1).
2. Merge remaining sessions to the current file. Procedure: Data → Merge Files → Add Cases → in "Add Cases to subjectID_session1.sav"

window, click Browse and choose file subjectID_session2  → Open  → Continue → in the "Add Cases from ..." window click OK. Repeat for
all remaining sessions. See Figure 8.

• ADD FILES /FILE=*
• /FILE='SubjectAB001_Session1.sav'.
• EXECUTE.

3. Add a column which contains the subject's ID number. Procedure: Transform → Compute Variable  → In "Compute Variable" window under
Target Variable, type SubjectID → click Type & Label to open "Compute Variable: Type an..." window → under "Type" select String →
Continue → under String Expression type 'SubjectID' (e.g. 'AB001') → OK. See Figure 9.

• STRING Subject_ID (A8).
• COMPUTE Subject_ID='AB001'.
• EXECUTE.
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4. Add a column that contains the subject’s target intensity (e.g. target heart rate [THR]). Procedure: Transform → Compute Variable  → In
"Compute Variable" window under Target Variable, type THR → click Type & Label to open "Compute Variable: Type an..." window → under
"Type" select Numeric → Continue → under Numeric Expression type THR (e.g. 110) → OK. See Figure 10.

• STRING THR (A8).
• COMPUTE THR='110'.
• EXECUTE.

5. Save database under a different file name (e.g. SubjectAB001_session1-36).
6. Repeat for all remaining participants. At this point, each participant will have a database containing all sessions.

4. Data Merging - Grouping Participants

1. To group several participants into a single database, open participant's file (i.e. subjectID_session1-36).
2. Merge the remaining participants to the current file. Procedure: Data → Merge Files → Add Cases → in "Add Cases to

SubjectAB001_session1-36.sav" window, click Browse and choose file SubjectCD002_session1-36  → Open  → Continue  → in the "Add
Cases from ..." window click OK. Repeat for all participants that you wish to group. See Figure 11.

• ADD FILES /FILE=*
• /RENAME (AB001=d0)
• /FILE='SubjectAB001_Session1-36.sav'
• /RENAME (CD002=d1)
• /DROP=d0 d1.
• EXECUTE.

3. Save new database (e.g.Group01_Subjects001-010).

5. Identification of Target Intensity (e.g. THR Range)

1. Identify a THR range; click Transform → Compute Variable → in the "Compute Variable" window under "Target Variable" enter a new variable
name (e.g. Diff_HR_THR) → "Type & Label..." → in the "Compute Variable: Type an...." select Numeric → Continue → Under "Numeric
Expression" enter equation: HR - THR → OK. This provides us with a new variable.

• COMPUTE Diff_HR_THR=HR - THR.
• EXECUTE.

2. Recode variables to identify whether the HR lies below, above, or within the THR range.  Procedure:Transform → Recode Into Different
Variables... → select Diff_HR_THR → click arrow → under "Output Variable" under "Name" type Diff_HR_THR _recoded → Change → Old
and New Values... → in "Recode Into Different Variables: Old and New Values" window:

Old Value New Value Old-->New:

Range: -5 through 5 1 -5 thru 5 --> 1

Range, LOWEST through value: -5 0 Lowest thru -5 --> 0

Range, value through HIGHEST: 5 0 5 thru Highest --> 0

System-missing System-missing

Add

SYSMIS--> SYSMIS

→ Continue → OK. See Figure 12.

• RECODE Diff_HR_THR (SYSMIS=SYSMIS) (-5 thru 5=1) (Lowest thru -5=0) (5 thru Highest=0) INTO
• Diff_HR_THR_Recoded.
• EXECUTE.

6. Calculation of Percent Adherence

1. In Group01_Subjects001-010 file, calculate all seconds that patients were within the THR range by doing the following: Data → Aggregate 
→ in "Aggregate Data" window, under "Break Variable(s):" select subjectID and session → click arrow → under "Summaries of Variable(s):"
select Diff_HR_THR _recoded  → click arrow → OK. A new variable is created with the name Diff_HR_THR _recoded_mean.

• AGGREGATE
• /OUTFILE=* MODE=ADDVARIABLES
• /BREAK=Subject_ID Session
• /Diff_HR_THR_Recoded_mean=MEAN(Diff_HR_THR_Recoded).

2. Convert the obtained value into a percentage; click Transform → Compute Variable  → under "Target Variable" enter variable name (e.g.
Perc_THR) → under "Numeric Expression" select Diff_HR_THR _recoded_mean → click arrow → multiply the value by 100 (Diff_HR_THR
_recoded_mean * 100)  → OK. We then obtain adherence as a percentage of time spent within the THR for each subject for each session.
See Figure 13

• COMPUTE Perc_THR=Diff_HR_THR_Recoded_mean * 100.
• EXECUTE.
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3. To obtain adherence for the percentage of time spent within the THR for each subject for all sessions combined, in "Aggregate Data" window,
under "Break Variable(s):" substitute subjectID and session with only subjectID. See Figure 14.

4. To obtain adherence for the percentage of time spent within the THR for each session for all subjects combined, in "Aggregate Data" window,
under "Break Variable(s):" substitute subjectID and session with only session.

5. Save the database under a different file name (e.g. Group01_Subjects001-010_Aggregate).

Representative Results

When the protocol is performed correctly, an adherence rate is obtained for each subject for each session (Figure 13), for each subject for all
sessions (Figure 14), and for each session for all subjects combined. An estimate of the time required to complete the above protocol for a
single session of one subject is approximately 5 min. Results for adherence can range from 0-100%. Using this information, additional analyses
can be performed to determine differences between subjects (i.e. sex differences, disease severity, etc.),to identify changes over time, and to
reveal patterns in adherence. Moreover, the comparison of adherence between groups can be performed; for example, different exercise training
programs can be compared. Finally, through further investigation, causes of nonadherence can be identified at specific time points during PR.

 

Figure 1. Heart rate transmitter placement. Click here to view larger image.

 

Figure 2. Sample of data collected using data tracking software. Click here to view larger image.
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Figure 3. Sample of data tracking software output. Click here to view larger image.

 

Figure 4. Sample database illustrating a sample of statistical software database. Click here to view larger image.
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Figure 5. Sample database illustrating the eliminated warm-up phase. Click here to view larger image.

 

Figure 6. Sample database illustrating the eliminated cool-down phase. Click here to view larger image.

 

Figure 7. Sample database illustrating a column added for session number. Click here to view larger image.
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Figure 8. Sample database illustrating the merged sessions for a single participant. Click here to view larger image.

 

Figure 9. Sample database illustrating a column added for subject identification number. Click here to view larger image.

 

Figure 10. Sample database illustrating a column added for target heart rate. Click here to view larger image.
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Figure 11. Sample database illustrating the merged participants' files. Click here to view larger image.

 

Figure 12. Sample database illustrating the recoded heart rate variables. Click here to view larger image.
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Figure 13. Sample database illustrating adherence as a percentage of time spent within the target heart rate range for each subject for
each session (horizontal red line highlights the change in adherence between sessions for the same subject). Click here to view larger image.

 

Figure 14. Sample database illustrating adherence for the percentage of time spent within the target heart rate range for each subject
for all sessions (horizontal red line highlights the difference between subjects). Click here to view larger image.

Discussion

Continuous data tracking technology enables for a very precise measurement of exercise adherence. This procedure can be easily adapted to
other definitions of adherence by replacing target heart rate range with target wattage, level, speed, or MET level. In the present example, the
warm-up and cool-down phases were eliminated to isolate the exercise phase because of our specific research objective. Should the warm-up
and cool-down phases be of interest to other researchers, step 2.3 ("Eliminate the nontraining phases") can be eliminated from the protocol.
Furthermore, the hardware and software is also available to measure adherence to other modes of training, such as the treadmill, elliptical,
stepper, and arm ergometer.

When following the above protocol, certain simple steps are critical. First, the CardioMemory software must be started before the exercise
equipment (e.g. cycle ergometer) for exercise data to be tracked and subsequently recorded. Should data be lost at this initial step, the data
extraction protocol will need to be adjusted accordingly. Secondly, sources of interference must be minimized to reduce the risk of crosstalk and/
or lost data. The heart rate monitors communicate wirelessly with the equipment and software. Thus, interference is especially detrimental if
using target heart rate to calculate adherence. Finally, it is imperative to select statistical software for the database that has the capacity to permit
for large quantities of data. For example, in a study with 10 participants completing 36 sessions at 40 min each, 864,000 rows of data points will
be generated. Excel 2007 and later versions have the capacity to contain 1,048,576 rows in a worksheet23, whereas SAS24 and SPSS25 have
no limit for the number of rows. Depending on the total number of data points expected for a given study, the software needs to be selected
accordingly.
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Despite the notable advantages of this technology, two main limitations exist. The first is data loss, which can result from equipment and/or
software failure. As mentioned above, data loss can be due to electrical interference with wireless devices (i.e. cell phones or Wi-Fi), and
more specifically interference with the wireless data transmission of heart rate. However, at times, data loss can also be due to unidentifiable
causes. A second limitation is that the software does not provide the option of marking or splitting the exercise protocol systematically in order
to differentiate/identify different phases. If this option were available, the extraction of the exercise phase of interest could be performed directly
in the software, which would limit steps in the adherence calculation protocol. As well, the option of placing markers would be practical for the
study of adherence to interval or intermittent training protocols as it would allow for the differentiation of the different phases (e.g. low versus high
intensity).

For future perspectives, the use of continuous data tracking technology to precisely quantify adherence will enable researchers to investigate
patterns of exercise response to different interventions, identify determinants of adherence, and characterize good and poor adherers. Ultimately,
a better understanding of exercise adherence will allow for the optimization of exercise rehabilitation programs.
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